Broadcom NetXtreme bcm5720 in the 9.1 beta

Hiroki Sato hrs at
Thu Aug 2 01:50:30 UTC 2012

Sean Bruno <seanbru at> wrote
  in <1343243969.2727.2.camel at>:

se> On Tue, 2012-07-24 at 18:46 -0700, Hiroki Sato wrote:
se> > Peter Feger <magickal1 at> wrote
se> >   in <CAD_3y4wAPp+8ZSveB6mbOF7M1Ne-zAvz4Uf=VV9quohUU23xHA at>:
se> >
se> > ma> I just got done installing FreeBSD-9.0 on a Dell R720.  I can tell you
se> > ma> that none of the broadcom products will work.  There is no driver that
se> > ma> I have been able to find.  I wound up having to replace them with
se> > ma> Intel nics.  I used the i350 quad-port 1G  and the x520 for 10G Fiber.
se> >
se> >  I recently bought a Dell R420 which had BCM 5720 as the LOM.  The
se> >  output of pciconf was the following:
se> >
se> > bge0 at pci0:2:0:0:        class=0x020000 card=0x04f81028 chip=0x165f14e4 rev=0x00 hdr=0x00
se> >     vendor     = 'Broadcom Corporation'
se> >     device     = 'NetXtreme BCM5720 Gigabit Ethernet PCIe'
se> >     class      = network
se> >     subclass   = ethernet
se> >
se> >  On 9.1-PRERELEASE as of Jul 23, it was recognized but did not work
se> >  properly first (the link-status went back and forth between up and
se> >  down).  However, after setting dev.bge.0.msi=0 it worked.  I am not
se> >  sure of whether it had decent communication speed or not, but I saw
se> >  it worked with 50MB/s or so at least.
se> >
se> >  IPMI over LAN did not work even if hw.bge.allow_asf was set to 1.
se> >
se> > -- Hiroki
se> For the r420/320 ... grab Pyun's latest updates and give it a whirl.
se> They seem to work for us at yahoo:

 Thanks!  I am testing his patches...

-- Hiroki
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url :

More information about the freebsd-stable mailing list