FreeBSD on IBM X3550 M3

Gót András andrej at
Tue Oct 18 21:41:22 UTC 2011

On Tue, 18 Oct 2011 09:03:05 +0200, Gót András wrote:
> On Mon, 17 Oct 2011 22:39:50 -0700, Jeremy Chadwick wrote:
>> On Tue, Oct 18, 2011 at 07:15:26AM +0200, G??t Andr??s wrote:
>>> On Mon, 17 Oct 2011 16:16:54 -0700, Xin LI wrote:
>>> >On Mon, Oct 17, 2011 at 2:45 PM, G??t Andr??s <andrej at>
>>> >wrote:
>>> >>Dear All,
>>> >>
>>> >>I'd like to install FreeBSD onto az IBM X3550 M3 which looks
>>> >>like UEFI only.
>>> >>Is it possible to have FreeBSD amd64 get working on it or should
>>> >>I forget
>>> >>it? :(
>>> >
>>> >Will it do traditional MBR boot by any chance?  As a last resort
>>> >workaround, it might be possible to take its hard drive to another
>>> >system and install grub which will boot FreeBSD but supports EFI.
>>> >
>>> >(We should implement EFI on amd64 by the way).
>>> >
>>> >Cheers,
>>> Take the hard drive out is not really an option because of the 
>>> M5014
>>> HW RAID and the SAS backplane. :)
>>> Anyway I found a "Rehook INT 19: disabled" setup option which, I
>>> think, simply disables legacy BIOS booting. I'll give it a try in
>>> the evening.
>> It's more likely that it provides the interrupt hook to getting a 
>> controller to boot from one of its underlying drives.  I guess 
>> there's
>> only one way to find out...  ;-)
> The M5014 RAID is also UEFI aware and of course I only made the
> initial disk group and volume group config on it. :)
> Yes, the moment of truth will come this evening. I hope I'll be able
> got FreeBSD working on the machine and I don't have to go on with
> Linux.
> For the record. I also found something about someone couldn't even
> boot Windows Server install CD on this machine and he had to update 
> to
> firmware. There's also something about OpenBSD that went with a clean
> install, but after the it freezes randomly.
> Andras

Thank you for all the tips. Fortunately it turned out to be simple. 
Finally, I got an USB DVD drive from my father and that made the trick. 
Memstick image or unetbootin pendrive installs won't work as it looks 
like. However, if I can help with testing memstick images I can do it 
until Oct 25. The unfortunate is that there not a single error about the 
memstick, it simply doesn't work. I also tried Ubuntu Lucid CD image 
written (with startup disk creator) to a pendrive and that also worked.

First I tried 9-BETA3, but that failed with cannot mount root error. 
(Sorry I couldn't save the exact error message.)

Then I thought I'll give a try to the 8.2-RELEASE. That worked out of 
the box with the RAID card and everything. The next big question is how 
easily will I install the 2 146GB disks that were left off the package. 
:) I'm going to find out it on Friday evening.



More information about the freebsd-stable mailing list