Dell PowerEdge 1950: MPT0 doesn't recogniz hard drive > 2TB

Jeremy Chadwick freebsd at
Wed Jun 29 08:33:57 UTC 2011

On Wed, Jun 29, 2011 at 09:58:02AM +0200, O. Hartmann wrote:
> On a Dell PowerEdge 1950, BIOS from 2007, a freshly installed  WD 3
> TB SATA 6GB harddrive doesn't get recognized as 3 TB disk, it is
> reported as 2TB disk only.
> The box is running FreeBSD 8.2-STABLE (see below the dmesg excerpt).
> The drive is configured as ZFS pool on top of a GPT partition.
> I tried the 3 TB harddrive on a FreeBSD 9.0-CURRENT box with Intel
> ICH10R SATA chipset and it worked fine, was reported as 2.7TB drive
> as expected.
> I found some postings concerning mptutil not dealing with HD > 2TB,
> but this issue seems not to be a tool-issue.
> Questions:
> a) Is this an issue of FreeBSD 8.2-STABLE or is it a firmware/BIOS
> issue which can be solved?
> b) regarding to a), how can I update the BIOS/MPT firmware of the
> Dell PowerEdge 1950? Is there an option to do this via USB? As I
> said, the firmware is quite old, it's from 2007.

The answer is here:

| Jeremy Chadwick                                jdc at |
| Parodius Networking              |
| UNIX Systems Administrator                   Mountain View, CA, US |
| Making life hard for others since 1977.               PGP 4BD6C0CB |

More information about the freebsd-stable mailing list