arcmsr panic runnig 8.2 of 2011

Jeremy Chadwick freebsd at
Sun Jun 26 11:01:24 UTC 2011

On Sun, Jun 26, 2011 at 01:53:17AM +0200, Willem Jan Withagen wrote:
> I'm running ZFS of of 8 disks on an areca 1120....
> Things were just running fine until I tried upgrading to the most recent
> Turns out that my configuration causes a panic in
> arcmsr.c:2093,
> Because the MTX is multiple invoked here.
> Now my previous working version dates from 26/2, and since then a new
> release from areca was imported.....
> So I tried opgrading my firmware to 1.49, but to no avail.
> The system keeps panicing.
> So I guess that there is still a coding error somewhere in the driver.
> But I'm not into this enough to even know where to start looking for
> tracing this.....
> But perhaps somebody has a suggestion?

Have you reported this problem directly to Areca?  They do officially
support FreeBSD.

| Jeremy Chadwick                                jdc at |
| Parodius Networking              |
| UNIX Systems Administrator                   Mountain View, CA, US |
| Making life hard for others since 1977.               PGP 4BD6C0CB |

More information about the freebsd-stable mailing list