gpt labels for zfs partitions don't appear in /dev/gpt

Bartosz Stec bartosz.stec at
Wed Jun 15 12:36:42 UTC 2011

W dniu 2011-06-15 14:12, Andrey V. Elsukov pisze:
> On 15.06.2011 15:43, Bartosz Stec wrote:
>> As you see I have ada{0-2}p3 labeled as disk{0-2} All labeled partitions have valid gpt id but
>> zfs partitions don't have accesible gpt label in /dev/gpt:
> It always worked so. Read geom(4) manual page, especially about SPOILING.
Ah, I see your point now.
>> As you see labels was firstly seen, but removed at the end. I tried to set blank label and then
>> correct one again, but no luck.
>> Any ideas what's possibly wrong here?
> There are two reasons:
> 1. glabel does not create providers for providers which are already in use.
> 2. `gpart modify` does not touch partition provider and it is not spoiled and retasted.
>> Problem appeared after my pool was broken and I imported it from some boot CD to fix this by "import
>> -F".
>> Now I have unreadable output from zpool commands, like this:
>>          NAME                                            STATE     READ WRITE CKSUM
>>          zroot                                           ONLINE       0     0     0
>>            raidz1-0                                      ONLINE       0     0     0
>>              gptid/2ea57c66-bc69-11df-8955-0050dad823cd  ONLINE       0     0     0
>>              gptid/5bc92016-6852-11df-a16c-0050dad823cd  ONLINE       0     0     0
>>              gptid/87d467cc-bc3b-11df-8066-0050dad823cd  ONLINE       0     0     0
> You can disable gptids and this output will be changed back:
> echo kern.geom.label.gptid.enable="0">>  /boot/loader.conf
Yes, indeed it did the trick. Thank you for your detailed explanation.

Bartosz Stec

More information about the freebsd-stable mailing list