BTX loader problem on specific hardware

Guido Falsi mad at
Thu Jun 9 15:28:28 UTC 2011


I'm having a problem with BTX hanging on an HP 6005 Pro PC.

I have filed a followup to an existing PR about this exact problem:

All the information there looks correct and stands true.

I have tried performing some trivial debugging on btxld and btx, but not
having any ASM skills and not knowing much about PC booting process I
could not conjure much.

It looks that it hangs between the end of btxld.S just before
relocating it's own start.8 routine and the first few instructions
in btx.S. Could really not make up much more.

I tried using old btx code, but it does not compile with present tools.
So I'm a little stuck.

I have the machine handy and can perform tests, run code and even debug
further if instructed a little on what needs to be done.

I hope someone with some specific knowledge could have a look at
this(strange) problem.

Thanks in advance!

Guido Falsi <mad at>

More information about the freebsd-stable mailing list