umass: AutoSense failed

Jan Winter thrawn at
Fri Jan 14 16:20:15 UTC 2011

On 12/14/2010 20:19, Ross Alexander wrote:
> On Sat, 11 Dec 2010, Harad Weiss wrote
>> Message: 7
>> Date: Fri, 10 Dec 2010 22:59:17 +0100
>> From: Harald Weis <hawei at>
>> Subject: Re: umass: AutoSense failed
>> To: freebsd-stable at
>> Cc: Jeremy Chadwick <freebsd at>
>> Message-ID: <20101210215917.GA2447 at>
>> Content-Type: text/plain; charset=us-ascii
>> [big snip]
>> The AutoSense failure occurs on two desktop computers, whether
>> motherboard or not, and on three laptops. As I said, all PC's
>> run 8.1-RELEASE.
>> What I do not know is whether the Sony DSC (Digital Still Camera) has
>> worked on 8.0-RELEASE. I didn't use it for some time, so I'm afraid
>> I never tried it on 8.x.
>> But I am sure it worked on all earlier releases.
>> In my original post I have forgotten to mention that I never had any
>> problems with all sorts of thumbdrives and USB disks.
>> Fortunately, I can read the 256MB CF memory of the DSC on an Ubuntu
>> laptop.
>> Could it possibly be a DSC hardware problem which is ignored by Ubuntu,
>> but not by FreeBSD?
> My Sony DSC camera did work under 8.0-RELEASE. It's a model DSC-W35.
> It's seeing the umass problem now, and has since 8.1-PRERELEASE afair.
> This fault is the same on i386 or amd64, intel or amd chipsets, USB
> 1.0 or 2.0, through hubs or straight off the m/b, etc.. I'm keeping a
> backup box (intel atom / i386) running 7.3-STABLE around specifically
> to work around the problem. I'd have said something eralier, but I've
> gotten used to small nits poppping up and then disappearing; this one
> is dragging along :(
> sincerest regards,
> Ross


I have similar problems. Running Freebsd 7.3 on a alix system 
I have no problems connecting usb hdd.

With freebsd 8.2-PRERELEASE, I got this errors after reading some data 
from the usb disk:

ugen1.2: <A-DATA> at usbus1
umass0: <A-DATA Portable HDD NH92, class 0/0, rev 2.00/1.40, addr 2> on 
umass0:  SCSI over Bulk-Only; quirks = 0x0000
umass0:0:0:-1: Attached to scbus0
da0 at umass-sim0 bus 0 scbus0 target 0 lun 0
da0: <A-DATA NH92 \\0000\\0000> Fixed Direct Access SCSI-0 device
da0: 40.000MB/s transfers
da0: 476940MB (976773167 512 byte sectors: 255H 63S/T 60801C)
(da0:umass-sim0:0:0:0): AutoSense failed
(da0:umass-sim0:0:0:0): SYNCHRONIZE CACHE(10). CDB: 35 0 0 0 0 0 0 0 0 0
(da0:umass-sim0:0:0:0): SCSI sense: NO SENSE asc:0,0 (No additional 
sense information)

any ideas?

cheers Jan

More information about the freebsd-stable mailing list