Enabling DDB prevent kernel from panicing

Mark Saad nonesuch at longcount.org
Tue Jan 11 00:42:25 UTC 2011

On Mon, Jan 10, 2011 at 6:59 PM,  <nickolasbug at gmail.com> wrote:
> Hello, Mark
> 2011/1/11 Mark Saad <nonesuch at longcount.org>:
>> All
>> This was originally posted to hackers@
>> I have a good question that I cant find an answer for. I believe
>> found a kernel bug in 7.3-RELEASE that prevents me from booting 64-bit
>> kernels on HP's DL360 G4p . The kernel dies with "Fatal trap 12: page
>> fault while in kernel mode " . The hardware works fine in 7.2-RELEASE
>> amd64, 7.1-RELEASE amd64, and 6.4-RELEASE amd64 .
>> In 7.3-RELEASE amd64 I can not boot from cd or pxe correctly using the
>> stock 7.3-RELEASE amd64 kernel however i386 works fine. To see if this
>> issue was some how fixed in 7.3-RELEASE-p4 amd64 I rebuilt a GENERIC
>> kernel using patches sources and tried to boot and I got the same
>> crash.
>>  Next I rebuilt the kernel with KDB and DDB to see if I could get a
>> core-dump of the system. I also set loader.conf to
>> kernel="kernel.DEBUG"
>> kern.dumpdev="/dev/da0s1b"
>> Next I pxebooted  the box and the system does not crash on boot up, it
>> will easily load a nfs root and work fine. So I copied my debug
>> kernel, and loader.conf to the local disk and rebooted and it boots
>> fine from the local disk .
> Looks like a race condition.
> Well, you don't need to compile KDB and DDB, just add
> makeoptions DEBUG=-g
> into your kernel config file and rebuild kernel.
> Then after you got a crash dump you can easy debug it (see FreeBSD
> Developers Handbok):
> http://www.freebsd.org/doc/en/books/developers-handbook/kerneldebug-gdb.html
> wbr,
> Nickolas

  Sorry let me clarify the issue, When you install a generic
7.3-RELEASE amd64 on some of the HP servers I use, the kernel panics
in boot up
when it probes the sio driver . Here is a part of my dmesg.boot file

atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [ITHREAD]
psm0: model Generic PS/2 mouse, device ID 0
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: <Standard PC COM port> port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A
sio0: [FILTER]
Say about here in the boot up , is where the box crashes with the
above noted error.

If I then boot the same box off a 7.1-RELEASE amd64 netboot server ,
mount the local disks of the 7.3-RELEASE install and edit the
/boot/device.hints and comment out the sio hints like this


then boot the server off the local disks , the server boots correctly.

The odd thing was, I rebuilt a debug 7.3-RELEASE amd64 kernel on
another working server, and installed it on the broken server and
booted it off the local disks, with out any changes to the hints file
and the server booted correctly and I was able to manually break out
into the debugger , but nothing looked wrong .

So to sum this up there is something broken in 7.3-RELEASE but I cant
figure out what. This server works with a generic install of
both amd64 and i386 , but not 7.3-RELEASE in amd64 . It also worked in
7.4-RC1 .

avg recommended I see what changed from r212964  to r212994 I am
currently looking into this . Has anyone seen this before ?


mark saad | nonesuch at longcount.org

More information about the freebsd-stable mailing list