umass: AutoSense failed

Harald Weis hawei at
Sun Jan 2 20:51:52 UTC 2011

On Tue, Dec 14, 2010 at 01:19:29PM -0700, Ross Alexander wrote:
> On Sat, 11 Dec 2010, Harad Weiss wrote
> >Message: 7
> >Date: Fri, 10 Dec 2010 22:59:17 +0100
> >From: Harald Weis <hawei at>
> >Subject: Re: umass: AutoSense failed
> >To: freebsd-stable at
> >Cc: Jeremy Chadwick <freebsd at>
> >Message-ID: <20101210215917.GA2447 at>
> >Content-Type: text/plain; charset=us-ascii
> >
> >[big snip]
> >
> >The AutoSense failure occurs on two desktop computers, whether
> >motherboard or not, and on three laptops. As I said, all PC's
> >run 8.1-RELEASE.
> >What I do not know is whether the Sony DSC (Digital Still Camera) has
> >worked on 8.0-RELEASE. I didn't use it for some time, so I'm afraid
> >I never tried it on 8.x.
> >But I am sure it worked on all earlier releases.
> >In my original post I have forgotten to mention that I never had any
> >problems with all sorts of thumbdrives and USB disks.
> >Fortunately, I can read the 256MB CF memory of the DSC on an Ubuntu
> >laptop.
> >Could it possibly be a DSC hardware problem which is ignored by Ubuntu,
> >but not by FreeBSD?
> My Sony DSC camera did work under 8.0-RELEASE.  It's a model DSC-W35.
> It's seeing the umass problem now, and has since 8.1-PRERELEASE afair.
> This fault is the same on i386 or amd64, intel or amd chipsets, USB
> 1.0 or 2.0, through hubs or straight off the m/b, etc..  I'm keeping a
> backup box (intel atom / i386) running 7.3-STABLE around specifically
> to work around the problem.  I'd have said something eralier, but I've
> gotten used to small nits poppping up and then disappearing; this one
> is dragging along :(
I haven't looked at the List for a while, so I only saw your message
yesterday. In the mean time, I've re-learned to work with bootable
memory sticks. I've had no luck yet with ReWritable CDs which I need for
all boxes but one. Perhaps a blanking problem?
Here is the summary of my trials in Fixit mode for my Sony DSC-P10 which
is also (at last) the answer to Jeremy's message:

7.2-RELEASE-i386-livefs:  OK

8.0-RELEASE-i386-memstick: OK

   AutoSense failed

   booting OK, but
   "No USB devices found!"
<message extract>
CAM status: SCSI Status Error
SCSI sense: UNIT ATTENTION asc: 28,0 (Not ready to ready
change, medium may have changed)
da0: 1915MB (3922944 512 byte sectors: 255H 63S/T 244C)
GEOM: da0: media size does not match label.
</message extract>

    AutoSense failed

Is it not a case for send-pr(1) ?

Best regards,

More information about the freebsd-stable mailing list