system crash during make installworld

David J Brooks freysman at
Tue Feb 22 03:16:32 UTC 2011

>>On 2011-Feb-21 08:04:00 +0000, David J Brooks <freysman at> wrote: 
>>As the subject suggests, my laptop crashed during make installworld. 
>>The new kernel boots, but the ELF interpreter is not found and I 
>>cannot get to a single user prompt. What is the least painful way to 
>My first suggestion would be to boot the previous kernel. If that doesn't 
>help, try specifying /rescue/sh as the single-user shell.> 
>If neither of those work, please specify the exact error message you 
>get and the point where you get it (if you don't have a serial console 
>available, post a link to picture of the screen showing the issue). 

I was able to boot the old kernel, but that didn't seem to help. Using /rescue/sh got me a usable prompt, and I was able to do a 'mount -a -t ufs' which got my hopes up, but trying to run 'make installworld' still gives me this: 

ELF interpreter /libexec/ not found 
Abort trap 

I looked in /libexec and found and 

I tried copying to and .old to and rebooting the old kernel in hopes that it would work. No joy. 

Next I made a copy of the 8.2-RC# install disk and tried to do an upgrade in place. It was unable to backup /etc to /var/tmp/etc due to: 

ELF interpreter /libexec/ not found 
Abort trap 

.. again. This happens pretty much anytime I try to execute a command that does not come from /rescue 

I really rather not do a clean install and lose all my configuration data, but it's increasingly looking like that may be my only option. 


More information about the freebsd-stable mailing list