VBox 3.2.8 & SATA virtual disks & FreeBSD 8.1-STABLE 20100912 -- (virtual) harddisks are not found on boot...

Alexander Motin mav at FreeBSD.org
Mon Sep 13 04:36:13 UTC 2010

Lev Serebryakov wrote:
>   I have VirtualBox-based FreeBSD 8.1 installation (32 bit, VirtualBox
> 3.2.8, WinXP/x64 host, but I thinks that host config is irrelevant).
>   Two   virtual  HDDs  are  atteched to virtual SATA adapter (channels
> 0 & 1) and CD/DVD attached to virtual IDE adapter (Primary master).
>   I've  used  FreeBSD  8.1-STABLE  builded  about  two  months ago and
> everything  worked  Ok with "Standard" (not AHCI) driver, root FS is
> ad4s1a.
>   I've    updated    FreeBSD    today   (12/09/2010)   with   csup   &
> buildworld/buildkernel/installworld/installkernel (GENERIC kernel).
>   Nothing was changed in VM config/setup.
>   Now   it   can not be booted because KERNEL doesn't see any HDDs and
> can not mount root FS. It shows only "acd0" as "GEOM managed disk device".
>   bootloader sees disk and reads kernel & modules without problems.
>   I've  tried  to "load ahci" on boot prompt, but result is almost the
> same.  AHCI  driver  sees  two channels, but got timeouts on both --
> oops, can not mout root FS again.

If ahci(4) also fails - at least enable verbose boot messages and send
me all that ahci(4) reports.

Alexander Motin

More information about the freebsd-stable mailing list