VBox 3.2.8 & SATA virtual disks & FreeBSD 8.1-STABLE 20100912 -- (virtual) harddisks are not found on boot...

Lev Serebryakov lev at FreeBSD.org
Sun Sep 12 20:34:32 UTC 2010

Hello, Freebsd-stable.

  I have VirtualBox-based FreeBSD 8.1 installation (32 bit, VirtualBox
3.2.8, WinXP/x64 host, but I thinks that host config is irrelevant).

  Two   virtual  HDDs  are  atteched to virtual SATA adapter (channels
0 & 1) and CD/DVD attached to virtual IDE adapter (Primary master).

  I've  used  FreeBSD  8.1-STABLE  builded  about  two  months ago and
everything  worked  Ok with "Standard" (not AHCI) driver, root FS is

  I've    updated    FreeBSD    today   (12/09/2010)   with   csup   &
buildworld/buildkernel/installworld/installkernel (GENERIC kernel).

  Nothing was changed in VM config/setup.

  Now   it   can not be booted because KERNEL doesn't see any HDDs and
can not mount root FS. It shows only "acd0" as "GEOM managed disk device".

  bootloader sees disk and reads kernel & modules without problems.

  I've  tried  to "load ahci" on boot prompt, but result is almost the
same.  AHCI  driver  sees  two channels, but got timeouts on both --
oops, can not mout root FS again.

  I've  tried  to  load  "vboxdrv"  (it  is build right after kernel &
world,  so  it  should  be in-sync), but here is abother fault: kernel
panics  in  "(swapper)"  process right after "acd0" detection (wihtout
vboxdrv  kernel  complains  about  missing  root  FS  exactly  at same

    I've googled this problem, but without any success. What should I do
to revive my VM?

// Black Lion AKA Lev Serebryakov <lev at FreeBSD.org>

More information about the freebsd-stable mailing list