Serial console problems with stable/8

Oliver Fromme olli at
Sun Sep 12 15:26:30 UTC 2010


On Friday I have updated a machine from 7.1 to stable/8.
It is connected to a serial console.  With 7.1 everything
worked fine, but with stable/8 things seem to break.

When the machine boots, everything appears normal, i.e.
I get all of the boot output, but then the console freezes.
The last thing that appears on the console is the time
stamp from the date(1) command at the very end of /etc/rc.
I do not get a login prompt, even though I see a getty
process on ttyu0.  No further output to the console
happens, commands like "echo foo > /dev/console" freeze,
too.  According to ps -alx they hang in "ttydcd".
I cannot even su(1) to root because it tries to print
a message to the console, so it hangs, too.  For the same
reason I can't use shutdown(8) either.  :-(

This is what a hanging su(1) command looks like in ps -alxww:
    0  1533  1532   0  76  0  3392  3180 ttydcd I+     0    0:00.05 su (zsh)

Interestingly, the KDB sequences CR ~ ^B/^P/^R/ do work,
which use the "low-level" console.  So only the "high-level"
console is frozen.

When I boot with the getty on ttyu0 switched off in
/etc/ttys, the console does *not* freeze, and output to
/dev/console works normal (I don't get a login prompt,
of course).  I can use su(1), shutdown(8) and so on.
But as soon as I try to start a getty on ttyu0, the darn
thing ceases to work.

Here's my setup (which worked perfectly fine with 7.1):



ttyu0   "/usr/libexec/getty std.9600"   vt100   off secure


uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
uart0: [FILTER]
uart0: console (9600,n,8,1)

The serial port is connected to another PC that runs tip(1)
in a screen(1) session, using a 9-pin nullmodem cable.
That setup hasn't changed in ages; that other PC is running
an older version of FreeBSD.

I need this issue to be resolved, because the serial console
is required for remote management (the machine is a 3-hours
ride away from home).  If it can't be resolved, I will have
to downgrade it to 7.x.

Best regards

Oliver Fromme, secnetix GmbH & Co. KG, Marktplatz 29, 85567 Grafing b. M.
Handelsregister: Registergericht Muenchen, HRA 74606,  Geschäftsfuehrung:
secnetix Verwaltungsgesellsch. mbH, Handelsregister: Registergericht Mün-
chen, HRB 125758,  Geschäftsführer: Maik Bachmann, Olaf Erb, Ralf Gebhart

FreeBSD-Dienstleistungen, -Produkte und mehr:

I suggested holding a "Python Object Oriented Programming Seminar",
but the acronym was unpopular.
        -- Joseph Strout

More information about the freebsd-stable mailing list