Problems replacing failing drive in ZFS pool

Garrett Moore garrettmoore at
Mon Jul 19 22:04:13 UTC 2010

Well, hotswapping worked, but now I have a totally different problem. Just
for reference:
# zpool offline tank da3
# camcontrol stop da3
<swap drive>
# camcontrol rescan all
<'da3 lost device, removing device entry'>
# camcontrol rescan all
<'da3 at mpt0 ...', so new drive was found! yay>
# zpool replace tank da3
*cannot replace da3 with da3: device is too small*

So I looked at the smartctl output for the old and new drive. Old:
Device Model:     WDC WD15EADS-00P8B0
Serial Number:    WD-WMAVU0087717
Firmware Version: 01.00A01
User Capacity:    1,500,301,910,016 bytes

Device Model:     WDC WD15EADS-00R6B0
Serial Number:    WD-WCAVY4770428
Firmware Version: 01.00A01
User Capacity:    1,500,300,828,160 bytes

God damnit, Western Digital. What can I do now? It's such a small
difference, is there a way I can work around this? My other replacement
drive is the "00R6B0" drive model as well, with the slightly smaller

On Mon, Jul 19, 2010 at 4:09 PM, John Hawkes-Reed <hirez at>wrote:

> On 19/07/2010 17:52, Garrett Moore wrote:
>> I'm nervous to trust the hotswap features and camcontrol to set things up
>> properly, but I guess I could try it. When I first set the system up
>> before
>> I put data on the array I tried the hotswap functionality and drives
>> wouldn't always re-attach when reinserted, even if I fiddled with
>> camcontrol, but I can't remember exactly what I did then.
> We've a pair of medium-sized ZFS boxes with Supermicro boards (X8DTi, IIRC)
> in hotswap chassis. They've both got one hot-spare drive. Well, I say 'hot
> spare'. I mean 'Ought to be a hot-spare if my shoddy Perl works when
> triggered by devd'. What we've found to work is this:
> Drive fails (thus far simulated by pulling the drive from the backplane)
> ZFS error reported. Pool in degraded state.
> 'zpool replace pool da9 da23' (Where da23 is the hot spare and where this
> *should* happen automagically.)
> Wait for resilvering.
> Go on and swap the failed drive (da9 in this case)
> 'camcontrol rescan all' (new drive shows up in /var/log/messages)
> 'zpool replace da9'
> Wait while resilvering happens.
> Hot-swap drive returns to 'avail' status.
> [ ... ]
> --
> JH-R
> _______________________________________________
> freebsd-stable at mailing list
> To unsubscribe, send any mail to "freebsd-stable-unsubscribe at"

More information about the freebsd-stable mailing list