Random Network Drops on Realtek Interfaces (re)

Alexandre "Sunny" Kovalenko gaijin.k at gmail.com
Tue Sep 22 12:55:36 UTC 2009

On Mon, 2009-09-21 at 23:25 -0600, Cassidy Larson wrote:
> All,
> I've been experiencing an intermittent issue with a drop in networking
> connectivity on a couple of boxes.
> At random times I drop connectivity between the servers and their
> gateway. I am able to login via the secondary interface and
> "/etc/netstart" and everything starts behaving as normal. My switch
> shows the link is up, ifconfig shows the link is up, but I am unable
> to ping my gateway until running "/etc/netstart".  Somedays it'll
> happen a few times an hour, some days once every 8-10 hours. It really
> is intermittent, and driving me crazy trying to track down the issue.
> I've tried different cables, switches, gateways, IPs, and locations.
> Memtest for 5 days showed no errors. However, the same problem exists
> on two separate installs at different times.  I am able to connect to
> the one server from the second via their secondary interfaces, so the
> problem isn't related to both network interfaces.
> Both servers have the Supermicro X7SLM-L motherboard, same CPU, RAM
> and disks.  Using the Realtek network driver (re). pciconf shows:
>     vendor     = 'Realtek Semiconductor'
>     device     = 'Gigabit Ethernet NIC(NDIS 6.0) (RTL8168/8111)'
>     class      = network
>     subclass   = ethernet
> I've experienced the problem for some time now on both 7.2-RELEASE and
> 7.2-STABLE (09/20/09) using amd64.
> Any help or suggestions would be useful in getting to the bottom of this.
I do not know how applicable this is in your case, but I have seen such
behavior when speed auto-negotiation was allowed on the box connected to
the Cisco switch. Condition was usually triggered by the certain volume
of traffic (e.g. system could be fine for weeks with SSH/telnet/X11 and
lose interface when someone sends large file over FTP or SCP).
Restarting the interface, usually fixed it for a while.

In my case it was platform-agnostic causing me to have a cheat-sheet on
how to disable auto-negotiation on AIX/Solaris/Linux/etc.

Alexandre Kovalenko (Олександр Коваленко)

More information about the freebsd-stable mailing list