8.0-BETA-4: no mouse or keyboard in X.

Patrick Lamaiziere patfbsd at davenulle.org
Sun Sep 13 10:57:39 UTC 2009

Le Sun, 13 Sep 2009 15:29:58 +1000,
Dave Hardman <dave at hardman.name> a écrit :

>     I upgraded from 7.2 to 8.0-BETA4. Now X will not receive input
> from either the mouse or keyboard. When this has happened in 7.1
> or 7.2 it was fixed by running hal. The keyboard, mouse and hal
> are all working. I did not configure X, the xorg.conf file was
> auto generated when X was first started.
>     I have tried a few things; new xorg.conf with Xorg -configure, 
> putting config files, which I found in a mailing list, in
> /usr/local/etc/hal/fdi/policy. Using a different window manager.
> Nothing worked.
>     Theres nothing in the log files that I recognise. Xorg.log
> reported "config/hal Adding input device AT Keyboard."

You need to rebuild hal and to remove the old libusb port.
libusb is now part of the base system in 8.X and you must use this
version. You should rebuild all that depend on the old port libusb (at

>     I also noticed the fuse.ko will not load, reporting "Exec
> format error."

Did you rebuild this module too?

More information about the freebsd-stable mailing list