8.0-BETA-4: no mouse or keyboard in X.

Dave Hardman dave at hardman.name
Sun Sep 13 05:48:12 UTC 2009

    I upgraded from 7.2 to 8.0-BETA4. Now X will not receive input
from either the mouse or keyboard. When this has happened in 7.1
or 7.2 it was fixed by running hal. The keyboard, mouse and hal
are all working. I did not configure X, the xorg.conf file was
auto generated when X was first started.

    I have tried a few things; new xorg.conf with Xorg -configure, 
putting config files, which I found in a mailing list, in
/usr/local/etc/hal/fdi/policy. Using a different window manager.
Nothing worked.

    Theres nothing in the log files that I recognise. Xorg.log
reported "config/hal Adding input device AT Keyboard."

    Any suggestions

    I also noticed the fuse.ko will not load, reporting "Exec
format error."
dave at loc:/usr/home/dave $ uname -a
FreeBSD loc.alh.ost 8.0-BETA4 FreeBSD 8.0-BETA4 #0: Sun Sep  6 04:44:31 UTC 2009     root at mason.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64

Thanks Dave

More information about the freebsd-stable mailing list