Rare problems in upgrade process (corrupted FS?) [SOLVED]

Jeremy Chadwick koitsu at FreeBSD.org
Fri Sep 26 12:21:39 UTC 2008

On Fri, Sep 26, 2008 at 02:12:08PM +0200, Jordi Espasa Clofent wrote:
> Finally I've modified the stable-supfile TAG from
> *default release=cvs tag=RELENG_7_0
> to
> *default release=cvs tag=RELENG_7
> and... voilà!... it works!
> I've interrupted the csup process (^C) and change again the tag to
> *default release=cvs tag=RELENG_7_0
> and it works perfecty.
> Maybe it's so stupid as the first tag was miss-typed... but I think not.  
> I checked it several times.
> I'ts solved, but I don't understand yet.

The part that doesn't make sense to me is why csup using
/usr/share/example/cvsup/stable-supfile did not work for you.  That file
contains tag=RELENG_7.

Are you modifying this file?  If so, please don't.  Make a copy of it
somewhere and refer to that location.  /root might be a good place.

The next time you install world, /usr/share/examples will be
overwritten, and you'll lose your changes.

| Jeremy Chadwick                                jdc at parodius.com |
| Parodius Networking                       http://www.parodius.com/ |
| UNIX Systems Administrator                  Mountain View, CA, USA |
| Making life hard for others since 1977.              PGP: 4BD6C0CB |

More information about the freebsd-stable mailing list