RELENG_7 hangs on boot w/Gigabyte MA78GM-S2H MB

Bob Willcox bob at
Sat Sep 20 13:24:34 UTC 2008

On Sat, Sep 20, 2008 at 05:39:14AM -0700, Jeremy Chadwick wrote:
> On Fri, Sep 19, 2008 at 11:24:18PM -0500, Bob Willcox wrote:
> > Hi All,
> > 
> > I'm trying to get the latest RELENG_7 to run on my new Gigabyte
> > MA78GM-S2H motherboard and am experiencing a hang on boot right after it
> > prints the message:
> > 
> > Trying to mount root from ufs:/dev/ad4s1a
> >
> > At this point it is hung and doesn't respond to any keyboard input.
> >
> > I originally attempted to install the 7.1 beta system with similar
> > results (prevented me from installing). I then installed 7.0-release
> > and though the install succeeded it never did "see" the Realtek
> > ethernet controller so I had no network capability.
> You're describing multiple problems in a single Email.  This is liable
> to get complex.

Sorry, that wasn't my intention. I was just trying to document my
experience with this particular motherboard (I have a number of others
that work fine with FreeBSD 7-stable, this one I'm typing this on is a
very similar Gigabyte board in fact).

> 1) It would be helpful to know if you installed i386 or amd64 FreeBSD,

This is amd64 on this particular machine.

> 2) With regards to the lock-up after "mount root", if you press NumLock
> or CapsLock, do the keyboard LEDs turn on/off?

Nope, no keys do anything. You must either push reset or pull the plug.

> 3) Many others have seen the hanging/lock-up after "mount root".  I
> believe one found a workaround by setting ATA_STATIC_ID in their kernel
> configuration.  I realise this is a problem when you can't get the
> system up to a point of building a kernel; chicken-and-egg problem,

Well, I can build a kernel if I run the 7.0-release kernel. That's how I
got to 7-stable on the machine in the first place. I used "sneaker net"
to copy it to this one via a CD (as I mentioned, the 7.0 kernel boots
but the Realtek ethernet device is not recognized).

> 4) The Realtek NIC on that motherboard is probably too new to be
> supported under RELENG_7.  Realtek has a history of releasing different
> sub-revisions of the same NIC/PHY, and the internal changes are severe
> enough to cause the NIC to not work correctly (under any OS) without
> full driver support for that specific sub-revision.

That's what I suspected. The values displayed when doing a "pciconf -lv"
are similar as for this system I'm using to type this, but now that
I look closer and make a direct comparison, the failing device has a
rev=0x02 vs. rev=0x01 for the working one. The pciconf -lv output for
the failing mb is:

none3 at pci0:2:0:0: class=0x020000 card=0xe0001458 chip=0x816810ec rev=0x02 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'RTL8168/8111 PCI-E Gigabit Ethernet NIC'
    class      = network
    subclass   = ethernet

> All above said:
> Can you please try one of the RELENG_7 ISO snapshots at the below site,
> instead of the official 7.0-RELEASE ISO, and report back if that solves
> either of your problems?  The below site contains ISOs built daily,
> rather than monthly:

I'll be happy to try that, but the kernel I most recently tried was from 7-stable
source that I cvsup'd just yesterday. Since both the official 7.1-BETA and
very recent 7-stable hang the same way I suspect that all of the newer kernels
will experience this hang. Let me know if you still think it's worth trying one
of the snapshots. I do plan to try the ATA_STATIC_ID setting that you mentioned
above to see if that helps. Let me know if there is anything else I should try.
I am able to build kernels so long as I run the 7.0 kernel (and work around the
network problem).

Thanks for your time & response!


> -- 
> | Jeremy Chadwick                                jdc at |
> | Parodius Networking              |
> | UNIX Systems Administrator                  Mountain View, CA, USA |
> | Making life hard for others since 1977.              PGP: 4BD6C0CB |

Bob Willcox              All the evidence concerning the universe
bob at           has not yet been collected, so there's still hope.
Austin, TX

More information about the freebsd-stable mailing list