kern.maxdsiz on amd63 with i386 binaries

Joe Marcus Clarke marcus at
Fri Oct 24 21:15:59 PDT 2008

Chris Peterson wrote:
> Hello,
> I've got a handful of i386 boxes, and a handful of amd64 boxes running a
> 32-bit application, the reasons for this exact configuration mystify me
> as well as the deployment predates my time in the environment. Now that
> the dataset the application is loading is rapidly approaching 512MB
> we're starting to tweak kern.maxdsiz and kern.dfldsiz to 1GB.
> The i386 boxes are doing great, but we hit an issue with the amd64
> machines in that 64bit apps seem to work fine, but the 32bit apps
> running on the amd64 machines fail to be able to use more than the i386
> default of 512MB no matter what we set kern.maxdsiz to. I've also tried
> compiling it into the kernel, which results in the same issue.
> I tried starting the app with "limits -d 1090519040", and it seems to
> fail as well. Limits does show the proper value for datasize of 1064960 kB.
> We're locked into 32-bit binaries for this app at the moment thanks to
> some uh... interesting libraries it uses, so the usual option of
> recompile isn't available. I'd like to avoid traveling from San Jose to
> Seattle, then Virginia, then Munich to reinstall the amd64 machines with
> i386 machines if at all possible.
> Uh... help?

Have you tried setting compat.ia32.maxdsiz?  I believe this will do what
you want.


Joe Marcus Clarke
FreeBSD GNOME Team	::	gnome at
FreeNode / #freebsd-gnome

More information about the freebsd-stable mailing list