Userland PPP not deleting old IP on disconnect

Daniel O'Connor doconnor at
Fri Oct 24 16:48:16 PDT 2008

On Wednesday 22 October 2008 00:30:45 Mike Tancsa wrote:
> At 05:57 AM 10/21/2008, Daniel O'Connor wrote:
> >I've even tried /etc/rc.d/pf restart but that doesn't fix it.. It's very
> >perplexing :(
> Strange, Even doing
> /sbin/pfctl -Fall -f /etc/pf.conf
> does not help as part of ppp.linkup ?  Perhaps confirm its actually
> working as expected.  e.g. wrap a small script around it so

I haven't tried it.. I did state & nat with no effect :(

> pppoe:
>   ! /usr/local/bin/
> where is something like
> /sbin/pfctl -sa -v > /var/log/
> /sbin/pfctl -Fall -f /etc/pf.conf > /var/log/
> and make sure the old states are actually gone and the rules make sense.

I've updated to 7.1-PRE but no luck, I still get the problem.

'' has what I would expect and '' is empty..

Hmm.. It seems that if I restart PPP it comes good but I don't really know 
why. ie it's as if the old IP address is still somehow associated with the 
tun interface until it's reopened..?

Thanks for the help BTW :)

Daniel O'Connor software and network engineer
for Genesis Software -
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url :

More information about the freebsd-stable mailing list