7.1 prelease, dump, dtrace

Tony Maher tonymaher at optusnet.com.au
Fri Oct 17 12:59:37 PDT 2008


Just some observations.

I upgrade from 7.0 release to 7.1 prerelease (Oct 16) which went
fine as usual :-)
Then wanted to try dtrace.  Initially just added options
options         KDTRACE_HOOKS
options         DDB_CTF
options         KDTRACE_FRAME

Made kernel and rebooted ok.  Then read handbook and followed
# cd /usr/src
# make WITH_CTF=1 buildworld
# make WITH_CFT=1 kernel
# make WITH_CFT=1 installworld
# mergemaster -Ui


GEOM: new disk ar0
Trying to mount root from ufs:/dev/ar0s2a
start_init: trying /sbin/init
init died (signal 6, exit 0)
panic: Going nowhere without my init!
cpuid = 0
Uptime: 6s
Cannot dump. No dump device defined.
Automatic reboot in 15 seconds - press a key on the console to abort

Hmmm.  Run restore from backup disk (7.0) cvsup again and reinstall 7.1
Do the dtrace kernel mods and just make kernel WITH_CFT=1.
Reboot everything appears ok.  Power up the USB disk used for backups.
Hmmm. Hard lock. Page fault in usb3.
Load up kernel with dtrace but not with WITH_CFT=1.
Same problem.
Next time power on disk before booting.  Boots ok and usb disk mounts ok.
Ok rebuild kernel without any dtrace options and reboot.
Now can power on usb disk after booting and it all works ok.

Ok - so stay away from dtrace for now!

On another subject dump.
I dump to a usb disk and to save space pipe output thru gzip
before sending to disk
$DUMP $ARGS -$LVL -f - /dev/$fs | gzip -1 -c > $dumpfile ;
This has been working fine.  A month ago I got a new larger usb disk
so tried to send directly to disk and avoid the gzip.
Dump stalled.  Tried thru gzip to new disk - works fine.
I saw the threads about dump stalling so stuck with piping thru gzip.
Read it is supposed to be fixed under 7.1 so tried dump direct to disk
under 7.1 and it works fine!

System is
FreeBSD 7.1-PRERELEASE #6: Fri Oct 17 19:55:21 EST 2008
    root at karma.home:/usr/obj/usr/src/sys/KARMA
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(TM)2 Duo CPU     E6750  @ 2.66GHz (2687.71-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x6fb  Stepping = 11
  AMD Features=0x20100800<SYSCALL,NX,LM>
  AMD Features2=0x1<LAHF>
  Cores per package: 2
usable memory = 4208721920 (4013 MB)
avail memory  = 4049219584 (3861 MB)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <INTEL DP35DP> on motherboard

So dump good, dtrace not so good! (dtrace -l worked)
Everything else appears to be working fine.
Thanks for all the hard work.

Tony Maher                    email: tonymaher at optusnet.com.au

More information about the freebsd-stable mailing list