am2 MBs - 4g + SCSI wipes out root partition

Jeremy Chadwick koitsu at
Sat Oct 11 09:52:54 PDT 2008

On Sat, Oct 11, 2008 at 12:26:29PM -0400, Adam McDougall wrote:
> Jeremy Chadwick wrote:
>> On Sat, Oct 11, 2008 at 04:45:29PM +0200, Gary Jennejohn wrote:
>>> On Sat, 11 Oct 2008 03:13:16 -0700
>>> Jeremy Chadwick <koitsu at> wrote:
>>>> On Sat, Oct 11, 2008 at 11:30:57AM +0200, Gary Jennejohn wrote:
>>>>> On Fri, 10 Oct 2008 14:29:37 -0300
>>>>> JoaoBR <joao at> wrote:
>>>>>> I tried MBs as Asus, Abit and Gigabyte all same result
>>>>>> Same hardware with SATA works perfect
>>>>>> Same hardware with scsi up to 3.5Gigs installed works perfect
>>>>>> what calls my attention that all this MBs do not have the 
>>>>>> memroy hole remapping feature so the complete 4gigs are 
>>>>>> available what normally was not the case with amd64 Mbs for the 
>>>>>> Athlon 64 CPUs
>>>>>> some has an opinion if this is a freebsd issue or MB falure or 
>>>>>> scsi drv problem?
>>>>> It's a driver problem.  If you want to use SCSI then you'll have to limit
>>>>> memory to 3.5 GB.
>>>> What you're saying is that Adaptec and LSI Logic SCSI controllers behave
>>>> badly (and can cause data loss) on amd64 systems which contain more than
>>>> 3.5GB of RAM.  This is a very big claim.
>>>> Have you talked to Scott Long about this?
>>>> Please expand on this, and provide evidence or references.  I need to
>>>> document this in my Wiki if it is indeed true.
>>> See the freebsd-scsi thread with Subject "data corruption with ahc driver
>>> and 4GB of memory using a FBSD-8 64-bit installation?" from Wed, 30 Jan
>>> 2008.
>>> This was for ahc, but the bit-rot which Scott mentions in his reply might
>>> also apply to the LSI Logic controllers.
>>> Basically the driver doesn't correctly handle DMA above 4GB.  Since the PCI
>>> hole gets mapped above 4GB it causes problems.  the (S)ATA drivers don't seem
>>> to have this problem.
>> Thank you -- this is the exact information I was looking for.
>> I will update my Wiki page to reflect this quite major problem.
> I am using some LSI (mpt driver) ultra4 (U320 scsi) and LSI SAS  
> controllers in FreeBSD 7.x amd64 with 20G of ram, and Adaptec (aac  
> driver) with a 5th generation RAID card with 8G of ram, both have no  
> such corruption problems.  Providing this as a counter-example just to  
> document some evidence of which products seem to work fine.

Is your LSI SAS controller driven by mpt(4) or mfi(4)?

Let's break down what we know for sure at this point:

aac(4) - not affected
aha(4) - unknown
ahb(4) - unknown
ahc(4) - affected
ahd(4) - unknown; no one answered the OP's question in the thread
asr(4) - unknown
ips(4) - unknown
mpt(4) - not affected
mfi(4) - unknown
sym(4) - unknown

Could the problem be specific to certain firmware revisions on the

Also adding Scott Long to the CC list.

| Jeremy Chadwick                                jdc at |
| Parodius Networking              |
| UNIX Systems Administrator                  Mountain View, CA, USA |
| Making life hard for others since 1977.              PGP: 4BD6C0CB |

More information about the freebsd-stable mailing list