am2 MBs - 4g + SCSI wipes out root partition

JoaoBR joao at
Fri Oct 10 10:30:40 PDT 2008

I get a problem on several am2 motherboards when an SCSI Adaptor (LSI or 
Adaptec) is installed and with 4Gigs of Ram

the problem is easy to repeat, after some minutes compiling world the machine 
crashes, sometimes a panic mmap ffs crossrefeerence or something, passes too 
fast to look an when the machine comes back often the complete root partition 
is gone or if not it needs manual fsck and mostly /dev references are gone or 
other important parts so the disk isn't bootable anymore

funny is (for me) that the other partitions are ok ever and only root is 
fucked ever

I tried MBs as Asus, Abit and Gigabyte all same result

Same hardware with SATA works perfect

Same hardware with scsi up to 3.5Gigs installed works perfect

what calls my attention that all this MBs do not have the memroy hole 
remapping feature so the complete 4gigs are available what normally was not 
the case with amd64 Mbs for the Athlon 64 CPUs

some has an opinion if this is a freebsd issue or MB falure or scsi drv 

Gigabyte support tips a driver problem and no MB issue. Other manufactures 
don't answer.

regarding the SCSI I tried the LSI U320, Adaptec U320 and Adaptec Raid SCSI 
(aacd) and all of them give me the same problem



A mensagem foi scaneada pelo sistema de e-mail e pode ser considerada segura.
Service fornecido pelo Datacenter Matik

More information about the freebsd-stable mailing list