can not wake on lan after halt -p (or shutdown -p now) on releng_7 and releng_7_0

Pyun YongHyeon pyunyh at
Fri Oct 10 01:23:02 UTC 2008

On Mon, Oct 06, 2008 at 06:13:34PM +0300, Georgi Iovchev wrote:
 > Hello list
 > I have a shutdown problem. I have a machine with gigabyte GA-G33M-DS2R
 > motherboard. Integrated network card is Realtek 8111B.
 > I can not wake the computer after I shutdown it from FreeBSD.
 > It is a dualboot system - windows xp and freebsd. If I shutdown the
 > computer from windows - later I can wake it up with magic packet. Even
 > if i shutdown the machine on the boot menu with the power button - than
 > later I can wake on lan. The only situation where I CANNOT wake it is
 > when I shutdown the machine from freebsd (halt -p).
 > First I tested with 7.0-RELEASE-p5 amd64 (RELENG_7_0) and than I
 > upgraded to 7.1 PRERELASE amd64 (RELENG_7). I also tested with two
 > network cards - the integrated one Realtek 8111B and another one Intel
 > PRO1000PT PCI-E with WOL enabled.

Don't know WOL issue of em(4) but re(4) should respond to WOL.
7.0-RELEASE had no support for WOL so RELENG_7 or 7.1-PRERELEASE
should be used to experiment WOL.

 > With both nics and both freebsd versions the situation is the same -
 > after shutdown from bsd the computer is not able to wake on lan. The

Because you can wake up your sytem from Windows shutdown I think
your BIOS is already configured to allow wakeup from WOL. Would
you compare ethernet address of re(4) to Winwods? Have you tried to
send Magic packets to FreeBSD box?
You may also try suspend your box with acpiconf and resume from WOL.

 > indication on the switch port says that after shut down there is
 > active link.

That indicates the controller is alive so it shall respond to WOL
if it was correctly configured to receive WOL packets. Have you
tried to send Magic packets to FreeBSD box?

 > Here is some information after last update:
 > [root at backup ~]# uname -a
 > FreeBSD 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #1: Mon Oct  6 17:01:26 EEST 2008     root at  amd64
 > [root at backup ~]# pciconf -lv
 > ...
 > re0 at pci0:3:0:0: class=0x020000 card=0xe0001458 chip=0x816810ec rev=0x01 hdr=0x00
 >     vendor     = 'Realtek Semiconductor'
 >     device     = 'RTL8168/8111 PCI-E Gigabit Ethernet NIC'
 >     class      = network
 >     subclass   = ethernet
 > ...

Show me dmesg output pertinent to re(4).

Pyun YongHyeon

More information about the freebsd-stable mailing list