Intel G33 & FreeBSD 7.x

Daniel O'Connor doconnor at
Mon Aug 18 10:32:23 UTC 2008

On Mon, 18 Aug 2008, Oliver Peter wrote:
> On Mon, 18 Aug 2008 17:16:36 +0930
> "Daniel O'Connor" <doconnor at> wrote:
> > Does anyone have a G33 chipset system working in 7.x?
> I have a working Q35 chipset (which is using the same driver)
> under latest -STABLE.
> 	FreeBSD 7.0-STABLE #0: Sat Aug 16 17:36:46 BST 2008
> > I have a 6.3 install here and it isn't working with that so I have
> > been merging things from HEAD but it still doesn't work.
> It has been in the source tree since 2007:
> ... and was finally enabled in -STABLE about two weeks ago:
> dmesg[1] is attached.

I MFC'd the AGP driver although quite possibly I stuffed something up. 
It does detect OK but X won't start with the ports intel driver.

I tried the GIT one but I can't get that to compile due to an old libdrm 
in ports :(

> > It would be worth switching to 7.x if it worked there though :)
> It is worth it anyway! :-) (zfs, zfs, zfs...)


> Unfortunately, the  drm  module does not recognize my chipset
> (so I don't have DRI support under X.ORG) - could be a problem with
> my hardware.  I would like to discuss that later this week on the
> list with more information.

I'd be very happy with accelerated 2D at this stage :)

Daniel O'Connor software and network engineer
for Genesis Software -
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part.
Url :

More information about the freebsd-stable mailing list