Intel G33 & FreeBSD 7.x

Guido Falsi mad at
Mon Aug 18 10:12:59 UTC 2008

On Mon, Aug 18, 2008 at 05:16:36PM +0930, Daniel O'Connor wrote:
> Does anyone have a G33 chipset system working in 7.x?
> I have a 6.3 install here and it isn't working with that so I have been 
> merging things from HEAD but it still doesn't work.
> It would be worth switching to 7.x if it worked there though :)

I'm using an HP DC7800, with a Q35 chip on it. It's working ok, and also
drm should work on it. I still have a few error messages from Xorg whihc
I could not diagnose, but they should be addressable.

Had to uncomment some code in the kernel though.

Look here:

my dmesg:

vgapci0: <VGA-compatible display> port 0x1230-0x1237 mem
0xf0100000-0xf017ffff,0xe0000000-0xefffffff,0xf0000000-0xf00fffff irq 16
at device 2.0 on pci0
agp0: <Intel Q35 SVGA controller> on vgapci0
agp0: detected 7676k stolen memory
agp0: aperture size is 256M

Guido Falsi <mad at>

More information about the freebsd-stable mailing list