em(4) on FreeBSD is sometimes annoying

Martin Sugioarto nakal at web.de
Tue Aug 12 11:49:21 UTC 2008

> For what it's worth, I have a T60 that dual boots 6.3-R/amd64 and 7.0-R/i386 
> and neither install has this problem.  I can cold boot it with the NIC 
> unplugged, plug in a cable, I get a link light and ifconfig em0 goes to 
> active, dhclient em0 gets an IP successfully.

Did you try to run /etc/rc.d/netif start after you've booted your laptop unplugged?

Try to do that, THEN connect the cable.

The problem appears ONLY in this situation. And it's quite common, because you often
use your laptop with wireless network and suddenly you decide to connect it to
wired network without having to switch the laptop off.

My NIC is in such a state that I am forced to switch it off, or else I don't get
link signal.

I don't think it's a BIOS firmware problem (I have tried every update).

I can remember that Linux had this issues, too a while ago. It works there now,
but FreeBSD is still the same. Please read the steps how I cause this situation.
It appears ONLY when you do it like I described it.

I've seen that people first boot with plugged in cable and start to play with dhclient.
Both is wrong.

Correct steps to reproduce is:
You have to start with unhooked interface AND the line ifconfig_re0="DHCP" in /etc/rc.conf.

Then wait until you can login and try to attach the cable.


EINE FÜR ALLE: die kostenlose WEB.DE-Plattform für Freunde und Deine
Homepage mit eigenem Namen. Jetzt starten! http://unddu.de/?kid=kid@mf2

More information about the freebsd-stable mailing list