Swapping boot disks and getting mountroot>===SOLVED

Lisa Besko besko at msu.edu
Thu Aug 7 18:43:13 UTC 2008

I got thinks working by commenting out
options         ATA_STATIC_ID   # Static device numbering
in the kernel.

I had to build a test kernel as described in /usr/src/UPDATING.

I still got my mountroot> prompt but for a change is showed me some
possible devices.  I was able to ad0s1a to boot from.  I rebooted to my
working kernel and edited /etc/fstab to use ad0.  Then booted my test
kernel again.

The system booted.  I installed the kernel w/o ATA_STATIC_ID and was
able to boot in my Sunfire X2100 and my X2200.


Lisa Besko wrote:
> Joseph Koshy wrote:
>>> I notice that it finds the device ad4 but then it tries to mount root 
>>> from
>>> /dev/ad6s1a.  I've edited the fstab to have it look for ad4s1a but it 
>>> still
>>> won't boot.  Anyone have any pointers or ideas?
>> Have you tried interrupting the boot sequence and setting new
>> values for the `rootdev' and `root_disk_unit' loader variables?
>> The loader(8) manual page has more information.
> No I haven't tried that yet.  Will that get me to a point where I can 
> trust it to boot on it's own to the correct disk all the  time?
> LB

Lisa Besko

More information about the freebsd-stable mailing list