Stable SATA pci card for FreeBSD 6.x/7.0

Sebastiaan van Erk sebster at
Tue Aug 5 13:13:01 UTC 2008


Thanks for the reply.

Jeremy Chadwick wrote:
> Yes, most of the Silicon Image ICs I've read about have odd driver
> problems or general issues (even under Windows).  The system rebooting
> is an odd one; you sure your PSU can handle two disks?

Well, I've got a 450W Asus PSU in there, but I've also got 6 hard disks
and 1 dvd-rom drive (mostly inactive) in there. The hard disks are
mostly 250/300GB but the two new ones are 1TB SATA drives. But the 450W
should easily be enough, shouldn't it?

>> Does anybody have experience with a (preferably not too expensive)  
>> 2-port SATA expansion card which does not have any issues running under  
>> FreeBSD 6.3/7.0?
> Promise makes some consumer-priced cards which work very well under
> FreeBSD (sos@ has full documentation on their cards).
> Their RAID controllers (the consumer-level ones) **do not** require that
> you use RAID; they support JBOD, and the disks will show up under
> FreeBSD as ad(4) devices.  (If you choose to use the RAID, you'll still
> see the ad(4) disks, but you'll also see an ar(4) device too.  This has
> the added advantage of you being able to monitor SMART stats on the
> disks themselves directly, etc...

I'll have a look at that if I can't get this one stable. They're
reasonably priced, so if they're good with FreeBSD then that looks like
a good option to me.

>> [pciconf -lv output]
>> atapci0 at pci0:10:0:      class=0x018000 card=0x35121095 chip=0x35121095  
>> rev=0x01
>> hdr=0x00
>>     vendor     = 'Silicon Image Inc (Was: CMD Technology Inc)'
>>     device     = 'Sil 3512 SATALink/SATARaid Controller'
>>     class      = mass storage
>> [/var/log/messages before the crash]
>> Aug  5 11:16:14 piglet kernel:  
>> g_vfs_done():mirror/gm1s1e[WRITE(offset=111376236544, length=16384)] error = 6
>> Aug  5 11:16:17 piglet last message repeated 9 times
> Are you sure this is being caused by the controller?  Have you checked
> SMART statistics on both disks?  Assuming error == errno, errno 6 is
> "Device not configured".

I did look at the smart stats [pasted them below]. What I will try next
is just to switch the two 250GB SATA drives on my main board with the
two 1TB drives on the controller and see if I still get the problems if
I really increase the load on the two 1TB drives.

> There's been recent discussion of such messages being caused by the use
> of gmirror or gjournal, when the mirror/journal is improperly set up.
> (In one users' case, he was receiving similar errors, as well as the
> filesystem failing during fsck.  Turns out he incorrectly configured
> journalling, which nuked the last ~1MB of his UFS filesystem.)
> I'm not saying this is the reason for the messages you see, but it's
> something to keep in mind.

I'll try reconfigure the geom. I used an online tutorial, but I'm not
quite sure that I did everything correctly, though fsck worked alright.
I did do this one differently than usual though, usually I use full disk
mirror after I already initialized one of the disks, and then I convert
it to a mirror by using:

sysctl kern.geom.debugflags=16
gmirror label -v -b round-robin gm0 /dev/ad0
gmirror insert gm0 /dev/ad2

(Especially useful when you want the entire FreeBSD install to be
mirrored). I guess I can try this on the extra disks as well.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3315 bytes
Desc: S/MIME Cryptographic Signature
Url :

More information about the freebsd-stable mailing list