Using Portupgrade?

Nic Reveles Nic.Reveles at
Mon Aug 4 01:45:21 UTC 2008


I've recently updated to freeBSD 6.3-STABLE from 5.3-RELEASE (amd64) and am struggling with out of date ports. I have tried updating 'ports-all' and 'src-all' numerous times (does src-all include ports-all? It takes forever) along with portupgrade.

For example, when trying to login to an account using the bash shell I got the following error that prevents logging in. Shared object "" not found 

So I tried: portupgrade -r bash, which did not fix anything. I was able to fix it by going into the ports directory and 'make deinstall' then 'make install'. But there are many other ports that are still broken. Is there an easy way to fix them all at once (using portupgrade)?

I've tried 'portupdate -ar', which had a lot of xorg installation errors... eventually I found an entry in '/usr/ports/UPDATING' about updating xorg. But following the instructions seems to give an error that suggests following the instructions!

1) I switched to portupgrade-devel following UPDATING instructions. I believe this was successful.
# portupgrade -f -o ports-mgmt/portupgrade-devel portupgrade
# rm -f /usr/ports/INDEX*.db /var/db/pkg/pkgdb.db
# pkgdb -fu

2) I rebuilt 'INDEX'
# cd /usr/ports && make index

3) I set environment variable 'XORG_UPGRADE' to 'yes'.

4) I gave portupgrade "a small bit of help" (quoting 'UPDATING')
# portupgrade -Rf libXft

5) I do not know if I have any gstreamer ports installed, so I tried both (neither did the trick).

# portupgrade -a -x 'gstreamer*'
--->  Upgrading 'xorg-libraries-6.8.2' to 'xorg-libraries-7.3_2' (x11/xorg-libraries)
--->  Building '/usr/ports/x11/xorg-libraries'
===>  Cleaning for xorg-libraries-7.3_2
/usr/X11R6 exists, but it is not a symlink. Installation cannot proceed.
This looks like an incompletely removed old version of X.  In the current version, /usr/X11R6 must be a symlink if it exists at all.Please read /usr/ports/UPDATING (entry of 20070519) for the procedure to upgrade related ports.*** Error code 1

Stop in /usr/ports/x11/xorg-libraries.
--->  Skipping 'x11/libdnd' (libdnd-1.1) because a requisite package 'xorg-libraries-6.8.2' (x11/xorg-libraries) failed (specify -k to force)
[a million more skipping errors...]

So I feel confident that I'm doing something incorrect since nothing seems to work after updating (or fails while updating). Could someone point me in the right direction?


More information about the freebsd-stable mailing list