Realtek RTL8110 (SB) watchdog timeout.

Eugene Butusov ebutusov at
Fri Aug 1 01:40:01 UTC 2008


   After updating from 7.0-RELEASE to STABLE (around 15/08) my NIC 
refuses to handle large file transfers.

pciconf -lv

re0 at pci0:4:0:0: class=0x020000 card=0x001a6409 chip=0x816910ec 
rev=0x10 hdr=0x00
     vendor     = 'Realtek Semiconductor'
     device     = 'RTL8110SB Single-Chip Gigabit LOM Ethernet Controller'
     class      = network
     subclass   = ethernet

Log messages:

re: watchdog timeout
re: link changed to DOWN
re: link changed to UP

When someone tried to copy large (i.e. 700MB) file from samba share 
(local gigabit network) or ftp (same LAN),
the NIC was reseted. For a while host was not accesible from the 
network, and then it came back with log messages shown above.
I've tried to tune samba socket options (SO_RCVBUF=16384 
SO_SNDBUF=16384), and this fixed the problem for samba users. One 
interesting thing: copying file to windows XP machine worked fine, 
while Vista (SP1 x64) caused the problem.

What solved the problem definitely was disabling TSO for re0 (ifconfig 
re0 -tso). I haven't notice any performance drop and it works fine, 
but I'm just curious what happened to the 'good' driver from 7.0-RELEASE.

Best regards,
_/_/   .. Eugene Butusov
  _/_/  ...
   _/_/ .... ebutusov(at)gmail(dot)com

More information about the freebsd-stable mailing list