FreeBSD-6.2 and MAPLE-9

carl at UDel.Edu carl at UDel.Edu
Sun Feb 11 00:23:21 UTC 2007

Dear FreeBSD:

Not entirely sure if this is the correct list to post this, but, I've recently installed FreeBSD-6.2 on a Pentium 3 box with 1-GB of memory.  I've tried to install all programs that I was able to run with FreeBSD-6.1, but the only one that gives me a difficulty so far is the mathematics package, MAPLE.  There are some difficulties with doing an installation (one needs to definitely have JDK-1.4 installed, and not just linux-JDK-1.4).  But even then, after doing the recommended fixes as found in the FreeBSD manual, I still get:

[carl at giediprime ~]$ cd maple9/bin
[carl at giediprime ~/maple9/bin]$ ./maple
maple: could not start server

This particular problem has some roots in the still current difficulty of running MAPLE using Fedora Core 4 (or higher).  I point this out, in that the package/port "linux-base" went from being based on Red-Hat 8 in FreeBSD-6.1 to being based on Fedora Core 4 in FreeBSD-6.2.  I was wondering if anyone else has run across problems with MAPLE, and what they have done to get around the problem.  I have translated over from FreeBSD-6.1 the "linux-base" based on Red-Hat 8, and have gotten MAPLE-9 to work in text mode, but cannot get the GUI to work.  To get that to work, it world seem that I have a great many packages/ports to bring over from FreeBSD-6.1, and was hoping there might be an easier method.  Anyone have any alternative thoughts?  Thanks for your help!

Best Regards,

More information about the freebsd-stable mailing list