Filesystem corruption and bad perfomance with SRCS16 and PAE (raid 5 2TB)

Artem Kuchin matrix at
Tue Feb 6 19:44:05 UTC 2007


I've got an Intel  2400A  server to install FBSD. It has 4GB RAM,
SRCS16 raid controller, configured 2TB (actually a little less, 
about 1.9TB) RAID-5 array, Xeon 3.2Ghz

Recently i have installed 6.2-R, cvsupped it to 6.2-STABLE
(today, thanks to included csup utility, very convinient) and
decided to turn on PAE so i can utilize all 4GB of RAM (w/o PAE
i am loosing 512MB, too bad).

I did that and then tried to run perl. Got  "segmantaion fault".
Ignored  that and tried to copy port tree and then i found
out that some files are damanged and connot be read. Also,
directoried could not be deleted because it is not empty, but when
i do ls in that dir it IS empty. weird.
Booted single user, did fsck - found  a buch of errors, many
softupdate inconsistencies.
Fixed them. Rebooted (still in PAE). Run buildworld and
copy ports tree at the same time. AFter 10 minutes again the same
Built a kernel without PAE, installed, rebooted in single user,
fixed all filesystems, booted multiuser, run buildworld and copy of
ports tree. Everything is okay. Did it many times. Still everything is ok.

Is it something bad about amr driver working under PAE?

Also, with and after running in PAE (i mean, run PAE kernel,
then install normal kernel and run it) the kernel compains like this
_vfs_done(): amrd0 [WRITE(offset=8192, length=1536)] error = 5
(no other message before  or aftrer this, disks are fully okay becuase
dd works like a charm)

Also, i did a simple thing
dd if=/dev/amrd0 of=/dev/null bs=1M (tried 2m, 5m, 512k)
The throughoutput is about 29MB/sec w/o PAE and 27MB/sec with PAE

Did the same on a very old DUal Pentium III with 3Ware 7xxxx with RAID-5
array and older harddrives. Got over 50Mb/sec.

unixbench show terrible number for file perfomance.

Why the heck amr is so slow? 

Artem Kuchin

More information about the freebsd-stable mailing list