dd as an imaging solution.

Sean Bryant sbryant at elgia.com
Sun Feb 4 01:06:22 UTC 2007

Several months ago I was using Freesbie 1.x to dd a harddrive across the 
network as a drive duplication effort. This worked 7 computers got the 
image. I'm trying to do this again so I got the new Freesbie release 2.0 
and fired it up across the computers and tried something simple such as:

dd if=/dev/ad0 bs=1m | nc othercomputer 10000 on the image provider

nc -l 10000 | dd of=/dev/ad0 bs=1m on the computer to receive the image.

I received an operation not permitted. My first thought was they must be 
mounted. a quick check, and it seems they weren't.
Next, am I really root? And sure enough I was. After a bit of discussion 
in #freesbie on freenode got me to set kern.geom.debugflags to 16 and I 
was able to write to ad0 like I had previously done. Yet when I tried to 
write to an individual slice I was presented with the same error.

Anyone have any clue ? The eventual goal is to have a mass imaging all 
at once with dd, nc and tee

More information about the freebsd-stable mailing list