2TB+ on ahd broken? (6.2-R)

John-Mark Gurney gurney_j at resnet.uoregon.edu
Mon Aug 27 11:49:31 PDT 2007

John-Mark Gurney wrote this message on Fri, Aug 17, 2007 at 15:46 -0700:
> I was just attempting to add a RAID shelf to a system w/ an Adaptec
> 29320 card, and when I export a 7TB disk to the card, and kept getting
> timeout related issues.  The dump is very similar to PR 76178 which
> appears to be reporting the same issue...
> I have attached a dmesg w/ the failure...  I tried various sizes and
> 1000000MB, 500MB and 2000000MB disks work...  When I tried the full
> 7TB or 2.3TB disk, ahd failed w/ the messages at the end of the
> dmesg.
> Is anyone even working on this?  As 2TB disks are coming soon, I'd
> imagine that ahd will need to get fixed before long, or are there just
> not many people use large disks w/ ahd?

For the archives:

After additional testing..  It appears that there was issues at U320
speeds even w/ the 500MB disk...  Slowing down to U160 made the 500MB
disk work, but the >2TB disk wouldn't be recognized...  I have also
tried a different cable, and w/ the different cable, the >2TB disk
shows up at U320 speeds, but sees broken behavior, the same as a
small disk...  The broken behavior at U320 being transfer rates in the
100-200KB/sec as ahd constantly resets...

> If ahd isn't getting fixed, can someone recommend a low profile PCI-X
> Ultra320 card?

I found a LSI (mpt) based card, and it's working great...

  John-Mark Gurney				Voice: +1 415 225 5579

     "All that I will do, has been done, All that I have, has not."

More information about the freebsd-stable mailing list