bge Ierr rate increase from 5.3R -> 6.1R

Greg Eden greg at
Tue Dec 12 07:08:19 PST 2006

Hello Doug

On 11 Dec 2006, at 21:46, Doug Barton wrote:

> Greg Eden wrote:
>> Hello
>> I recently updated two production servers from 5.3 to 6.1 via  
>> cvsup and
>> buildworld. Since the upgrade I've seen an increase in the number of
>> Input packet errors reported on the bge cards in on both boxes.  
>> One is a
>> HP DL360g3, the other is a HP DL380g3. Both have a pair of 2.8GHz  
>> Xeons
>> with a SMP kernel.
> It would be quite useful at this point if you could update a box or
> two to the RELENG_6_2 code base so that we can see if this problem is
> solved in the latest release candidate. If it is, your problem is
> solved, and if it's not, you're a lot closer to the point where we can
> usefully assist you.

I've just updated a box (HP DL360g4) to RELENG_6_2 as requested.  
Problem still appears to be present. sftping over 750MB of log files  
produced the characteristic errors.

netstat -i
Name    Mtu Network       Address              Ipkts Ierrs    Opkts  
Oerrs  Coll
bge0   1500 <Link#1>      00:12:79:3b:**:**   313091    24    
217911     0     0
bge0   1500 192.168.100   192.168.***.***     312894     -    
217905     -     -
bge1*  1500 <Link#2>      00:12:79:3b:**:**        0     0         
0     0     0
lo0   16384 <Link#3>                               0     0         
0     0     0
lo0   16384 your-net      localhost                0     -         
0     -     -

Here's the dmesg output for the box.

Copyright (c) 1992-2006 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
         The Regents of the University of California. All rights  
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-RC1 #0: Tue Dec 12 14:07:47 GMT 2006
ACPI APIC Table: <HP     00000083>
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Xeon(TM) CPU 3.00GHz (3000.12-MHz 686-class CPU)
   Origin = "GenuineIntel"  Id = 0xf41  Stepping = 1
   AMD Features=0x20100000<NX,LM>
   Logical CPUs per core: 2
real memory  = 1073688576 (1023 MB)
avail memory = 1045893120 (997 MB)
ioapic1: Changing APIC ID to 9
ioapic0 <Version 2.0> irqs 0-23 on motherboard
ioapic1 <Version 2.0> irqs 24-47 on motherboard
ioapic2 <Version 2.0> irqs 48-71 on motherboard
ioapic3 <Version 2.0> irqs 72-95 on motherboard
kbd1 at kbdmux0
acpi0: <HP P52> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-safe" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x908-0x90b on acpi0
cpu0: <ACPI CPU> on acpi0
pcib0: <ACPI Host-PCI bridge> on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 2.0 on pci0
pci13: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> at device 4.0 on pci0
pci6: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 0.0 on pci6
pci7: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 0.2 on pci6
pci10: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci3: <ACPI PCI bus> on pcib5
pcib6: <ACPI PCI-PCI bridge> at device 28.0 on pci0
pci2: <ACPI PCI bus> on pcib6
ciss0: <HP Smart Array 6i> port 0x4000-0x40ff mem  
0xfdff0000-0xfdff1fff,0xfdf80000-0xfdfbffff irq 24 at device 1.0 on pci2
bge0: <Broadcom BCM5704 B0, ASIC rev. 0x2100> mem  
0xfdf70000-0xfdf7ffff irq 25 at device 2.0 on pci2
miibus0: <MII bus> on bge0
brgphy0: <BCM5704 10/100/1000baseTX PHY> on miibus0
brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,  
1000baseTX-FDX, auto
bge0: Ethernet address: 00:12:79:3b:83:52
bge1: <Broadcom BCM5704 B0, ASIC rev. 0x2100> mem  
0xfdf60000-0xfdf6ffff irq 26 at device 2.1 on pci2
miibus1: <MII bus> on bge1
brgphy1: <BCM5704 10/100/1000baseTX PHY> on miibus1
brgphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,  
1000baseTX-FDX, auto
bge1: Ethernet address: 00:12:79:3b:83:51
uhci0: <UHCI (generic) USB controller> port 0x2000-0x201f irq 16 at  
device 29.0 on pci0
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0x2020-0x203f irq 19 at  
device 29.1 on pci0
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pci0: <base peripheral> at device 29.4 (no driver attached)
pci0: <base peripheral, interrupt controller> at device 29.5 (no  
driver attached)
ehci0: <Intel 6300ESB USB 2.0 controller> mem 0xfbee0000-0xfbee03ff  
irq 23 at device 29.7 on pci0
usb2: EHCI version 1.0
usb2: companion controllers, 2 ports each: usb0 usb1
usb2: <Intel 6300ESB USB 2.0 controller> on ehci0
usb2: USB revision 2.0
uhub2: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub2: 4 ports with 4 removable, self powered
pcib7: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci1: <ACPI PCI bus> on pcib7
pci1: <display, VGA> at device 3.0 (no driver attached)
pci1: <base peripheral> at device 4.0 (no driver attached)
pci1: <base peripheral> at device 4.2 (no driver attached)
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel 6300ESB UDMA100 controller> port  
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x500-0x50f irq 18 at device 31.1  
on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xc7fff,0xc8000-0xcbfff, 
0xee000-0xeffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on  
Timecounter "TSC" frequency 3000120023 Hz quality 800
Timecounters tick every 1.000 msec
acd0: CDROM <CRN-8245B/2.19> at ata0-master PIO4
da0 at ciss0 bus 0 target 0 lun 0
da0: <COMPAQ RAID 1  VOLUME OK> Fixed Direct Access SCSI-0 device
da0: 135.168MB/s transfers
da0: 69459MB (142253280 512 byte sectors: 255H 32S/T 17433C)
Trying to mount root from ufs:/dev/da0s1a
bge0: link state changed to UP

vmstat -i looks like this

interrupt                          total       rate
irq1: atkbd0                           8          0
irq14: ata0                           46          0
irq24: ciss0                        8093          6
irq25: bge0                       121771        102
cpu0: timer                      2373952       2005
Total                            2503870       2114

Let me know if you need anything more.


More information about the freebsd-stable mailing list