nForce 4, SATA Drive only runs at UDMA33?

alan bryan alanbryan1234 at
Mon May 23 11:39:54 PDT 2005

--- Doug White <dwhite at> wrote:
> I guess turning off the RAID converts the chips into
> standard SATA
> controllers. I'll have to look into that. An nForce
> 4 machine recently
> appeared at work, so I'll see what I can get it to
> do.

That's my understanding.  FYI: I also tried turning on
"RAID" in the bios and not actually assigning any of
the disks to any RAID sets and everthing behaved just
the same so it does't seem to matter whether it's on
or off in the bios (assuming no disks actually used in
an array).

> It looks like sos added support for atapci1 and 2 in
> this listing in the
> ATAmkIII patchset.  While that patchset is in
> -CURRENT you'll have to
> apply the -stable patches yourself. Search the list
> archives for the
> location, soren posts it now and again.

I upgraded my source from 5.4-RELEASE to 5-STABLE and
applied the patchset, compiled a new kernel, installed
it and rebooted.

(This was the "n" version of ATAmkIII which I think is
the latest.)

It booted, I saw something about ATAPI2 and 3 and SATA
and I got all excited for a second as I thought it was
going to work.  Then, a bunch of stuff flies by real
fast and it ends with the following and then hard
locks up.

(manually retyped as the machine locks)
...  (lots of those)
subdisk6: detached
ad6: detached
ata2: SATA connect status=00000000
ata3: SATA connect ready time=0ms

Any ideas?  I'm confused about the attach/detach stuff
as I'm not using any RAID, it's turned off in the
bios.  Just trying to get a single SATA drive to work.

To further probe and test I tried physically moving
the drive to other SATA sockets on the MB.  When I did
this I can get the system to boot up but it can't find
the file systems.  I manually told it where the root
filesystem was.  (it was now on ata5: so I told it
ad10s1a, it then completed loading root filesystem)
>From this point I thought, well, at least now I can
try atacontrol to see what's up.  atacontrol mode 5
showed the disk still at UDMA33!  I gave the command
atacontrol mode 5 UDMA133 BIOSIO to try to set it
higher but it didn't change anything.

So, I'm now out of ideas.  Anybody else have any?  I
could try -CURRENT but my understanding is that with
the 5-STABLE and the patchset I'm pretty much the same
ATA-wise, correct?

Thanks for all the help thus far!

--Alan Bryan

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the freebsd-stable mailing list