Problem booting 5.4

rduffner rduffner at
Sat May 14 13:19:56 PDT 2005

Doug White writes: 

> On Thu, 12 May 2005, Rainer Duffner wrote: 
>> Hi, 
>> I installed FreeBSD5.4 on a server with a 3ware 7006-2 controller and
>> two 120GB disks as RAID1
>> I cannot boot this install. (I get some kind of panic or endless loop,
>> but the display is re-painted so fast I cannot read it).
>> What I *can* do is insert my SuSE9.2-pro cd1, boot from that and at the
>> grub-menu say "boot from harddisk".
>> That boots FreeBSD. 
>> On advice from IRC, I tried:
>> # boot0cfg -B twed0 
>> -which leads to this output 
>> boot0cfg: write_mbr: /dev/twed0: No such file or directory
> This is a erroneous message. The actual problem is: 
>    484 boot0cfg NAMI  "/dev/twed0"
>    484 boot0cfg RET   open -1 errno 1 Operation not permitted 
> This is a known problem with certain MBR layouts. To work around this
> problem, set: 
> sysctl kern.geom.debugflags=16 
> then try your boot0cfg. There's a protection mechanism that sometimes gets
> confused by certain partition table layouts. Flag 16 disables that
> protection.  I don't recommend running this unless you are explicitly
> trying to updating something in a partition table-like area; its very easy
> to destroy your system with the flag set!

I booted from CD and ran the boot0cfg "offline" - however, this worked only 
on one server. I have two more identical servers that now just beep 
endlessly at the F1-prompt.
I was told it is a geometry problem, but what else can I do? 



More information about the freebsd-stable mailing list