nfs bug & df: Can I lock up my kernel and overflow this buffer?

Jonathan Noack noackjr at
Mon May 9 23:21:08 PDT 2005

On 05/10/05 00:21, Billy Newsom wrote:
> Jonathan Noack wrote:
>  > On 05/09/05 23:14, Billy Newsom wrote:
>  >  From the fstab(5) man page:
>  > "The fourth field, (fs_mntops), describes the mount options associated
>  > with the file system.  It is formatted as a comma separated list of
>  > options.  It contains at least the type of mount (see fs_type below)
>  > plus any additional options appropriate to the file system type.  See
>  > the options flag (-o) in the mount(8) page and the file system specific
>  > page, such as mount_nfs(8), for additional options that may be 
> specified."
> That is how I read the man page, too, long ago.  But when I tried the -o 
> option on the commandline, I was unable to send mount all of the 
> mount_nfs commandline switches I needed.  I either misunderstand the 
> mount -o option, or it doesn't work for all of the mount_nfs stuff I 
> tried to send it.
> In other words, the -o option seems to not like any of the many switches 
> understood by mount_nfs .... hence I seemed to be forced to use 
> mount_nfs directly.  And that precludes using it in fstab.

You are not restricted to only the -o option with fstab.  The native 
mount_nfs switches work fine with it.  This is stated in the second half 
of the last sentence I quoted above (note the "and").  Thus, the same 
options you use on the command line work with fstab.

>  > What trouble did you have with fstab?  You can specify as many options
>  > as you want as long as you separate them with commas (I think putting a
>  > '=' between an option and its value is also necessary, although I don't
>  > know for sure).  For you it should look like this (assuming you want
>  > read/write):
>  >
>  > dell:/nfs  /dellbak  nfs  rw,-s,-x=2,-T  0  0
> I don't know.  Since mount wasn't able to understand those switches on 
> the commandline, I never tried anything in fstab, for the sake of not 
> causing any problems with my boot.

The handbook page on nfs has a few simple examples toward the bottom 
(first hit on a Google search for "freebsd nfs fstab"):

To test the line I gave you just add it to /etc/fstab and see if "mount 
/dellbak" works.  It'll give you an error message if something is wrong. 
  For example, the options specified work perfectly for me and the mount 
command completes successfully.  Adding a "-z" to it gives an illegal 
option error.

# grep shared /etc/fstab
server:/shared  /mnt  nfs  rw,-s,-x=2,-T  0  0
# mount /mnt
# umount /mnt
<add "-z">
# grep shared /etc/fstab
server:/shared  /mnt  nfs  rw,-s,-x=2,-T,-z  0  0
# mount /mnt
mount_nfs: illegal option -- z
usage: mount_nfs [-23bcdiLlNPsTU] [-a maxreadahead] [-D deadthresh]
                  [-g maxgroups] [-I readdirsize] [-o options] [-R retrycnt]
                  [-r readsize] [-t timeout] [-w writesize] [-x retrans]
                  rhost:path node

> Anyone tried that sort of stuff in fstab?  I'm a little skeptical.

I use "that sort of stuff" and have for a long time.  Here's one of my 
fstab lines:

optimator:/usr/home  /usr/home  nfs  rw,-3,-T,-r=32768,-w=32768  0  0

It's obvious you don't believe me but why are you unwilling to try it 

Jonathan Noack | noackjr at | OpenPGP: 0x991D8195
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 187 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-stable mailing list