gvinum RAID5 stable in 5.4-RELEASE?

Michael L. Squires mikes at siralan.org
Mon May 9 20:10:46 PDT 2005

I tried to install a RAID5 array using both vinum and gvinum under 
5.3-RELEASE and couldn't get a reliable system running.  I reinstalled 
using 4.11-STABLE and so far the system (and vinum) have been error-free.

The 5.4-RELEASE documentation only mentions that "geom_vinum" provides a 
GEOM compatible replacement for vinum.  I've seen contradictory messages 
on this mailing list and the geom mailing list about whether 
5.4-RELEASE's "gvinum" provides a stable RAID5 solution.

Hardware is a Supermicro P4DC6+, dual 1.7Ghz Xeon, 512MB RAMBUS, boot 
device is a RAID1 array using an Adaptec 2005 in the RAID adapter slot,
8 Seagate 43GB SCSI disks attached to a Compaq/Adaptec 39160 controller
using vinum.  I don't want to use the on-board controller for the RAID5 
array since I believe the cabling will be problematical with two external 
SCSI towers plus the long run from the SCSI port to the back of the case.

I tried installing 5.3_RELEASE/RAID5 several times using both vinum and 
gvinum; I also tried installing and then upgrading to 5.3-STABLE in the 
hopes that a bugfix had appeared.  I had gvinum working for almost a day 
before the system crashed under heavy load; since this is a hobby and not 
my employment I decided to back off to 4.11 and try again.

I do have an alternative - a DPT SmartRAID V - but vinum has been so 
reliable under 4.x that I'd like to continue with it, if possible.

Mike Squires

More information about the freebsd-stable mailing list