Xorg - getting VESA to work on a Radeon Xpress 200?

Torfinn Ingolfsen torfinn.ingolfsen at broadpark.no
Fri May 6 21:26:53 PDT 2005

I have an amd64 machine, it has a RS480M2-IL (aka MS-7093) mainboard
(don't ask me what the '-IL' means, I have no idea).
I run the FreeBSD 5-stable branch on the machine:
root at kg-quiet# uname -a
FreeBSD kg-quiet.kg4.no 5.4-STABLE FreeBSD 5.4-STABLE #2: Tue May  3
22:40:03 CEST 2005     root at kg-quiet.kg4.no:/usr/obj/usr/src/sys/QUIET 

This mainboard have "ATI Radeon Xpress 200" integrated graphics, which
currently isn't supported by any ATI drivers, AFAIK. So I have to use
the VESA driver.
I run this with Xorg 6.8.2 from ports, using the vesa driver, on an LCD
that have 1280x1024 as native resolution. The problem has been that the
vesa driver behaves odd; text (any text) is "blurred" (for lack of a
better word) so that it is difficult / imposiible to read. Except for
that (not so small) problem, Xorg has been working without problems.

Recently I noticed that there was a new port; xorg-server-snap
(, so I tried that one. First I tried to autodetect drivers;
xorg suggested the 'ati' driver, but that makes a mess of the display.
so back to the vesa driver again. And to my joy I discovered that text
was crisp and readable again! Nice!
But there is one problem: xorg won't do 1280x1024 anymore.
The log file (/var/log/Xorg.0.log) contains this line:

(II) VESA(0): Not using mode "1280x1024" (no mode of this name)

Huh? Earlier on in the log file, it reported:
(II) VESA(0): Supported VESA Video Modes:
(II) VESA(0): 720x400 at 70Hz
(II) VESA(0): 640x480 at 60Hz
(II) VESA(0): 640x480 at 67Hz
(II) VESA(0): 640x480 at 72Hz
(II) VESA(0): 640x480 at 75Hz
(II) VESA(0): 800x600 at 60Hz
(II) VESA(0): 800x600 at 72Hz
(II) VESA(0): 800x600 at 75Hz
(II) VESA(0): 832x624 at 75Hz
(II) VESA(0): 1024x768 at 60Hz
(II) VESA(0): 1024x768 at 70Hz
(II) VESA(0): 1024x768 at 75Hz
(II) VESA(0): 1280x1024 at 75Hz
(II) VESA(0): 1152x870 at 75Hz

The complete Xorg.0.log file is attached.
I tried searching on the net (ok, "googling"), but didn't find anything
that helped.

Any hints on what I can try to fix this?
Torfinn Ingolfsen,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: application/octet-stream
Size: 83307 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20050505/10895093/Xorg.0.obj

More information about the freebsd-stable mailing list