Problems with AMD64 and 8 GB RAM?

David O'Brien obrien at
Thu Mar 31 10:59:03 PST 2005

On Thu, Mar 31, 2005 at 11:24:29AM +0930, Greg 'groggy' Lehey wrote:
> On Thursday, 31 March 2005 at 10:32:33 +0930, Daniel O'Connor wrote:
> > On Thu, 31 Mar 2005 08:14, Greg 'groggy' Lehey wrote:
> >>> Have you run sysutils/memtest86 with the 8 GB?
> >>
> >> Heh.  Difficult when the system doesn't run.
> >
> > You could try although that doesn't do >4Gb
> :(
> I'm pretty sure it's not the memory.  I've tried each pair
> individually, and it's only when they're both in there together that
> it's a problem.  And yes, I've tried them in each pair of slots.

You have a dual-channel memory controller.  If you insert one DIMM you
perform 64-bit data accesses.  If you install DIMM's in pairs (making
sure you're using the right "paired" sockets), you perform 128-bit data
accesses.  Thus your access pattern is different between these two
situations.  I'm highly suspious that you can us 4x2GB DIMM's with out
knowing the exact part number.  Don't forget 2GB DIMM's are
double-stacked and thus look like double the electrical bus loads.  The
same is true for older 1GB DIMM's.

Install all the memory you would like to use into your motherboard,
download memtest86+ version 1.40 from, dd to
floppy or burn the ISO, and report back your findings from running it.

Also what version of the BIOS are you using?

-- David  (obrien at

More information about the freebsd-stable mailing list