installworld fails (5.4-PRE) on acpica

Scott Robbins scottro at
Fri Mar 11 02:51:56 PST 2005

Hash: SHA1

On Fri, Mar 11, 2005 at 02:23:24AM -0500, epilogue wrote:
> > I deleted the FILE acpica and re-ran installworld. The directory
> > acpica was then created.
> worked here as well.  thanks.

Here too.  Though Mezz's post on the 4th or 5th indicated that he saw a
commit that should have fixed it, I had the same problem last night.

A quick recap for those who run into this.

After cvsup-ing and doing buildworld, buildkernel installkernel, during
make installworld, you get a stop  error about not being able to cd to

This is because /usr/include/dev/acpica is a file, not a directory.
Just delete /usr/include/dev/acpica before running make installworld 
and it will work. 

(To see if the problem is going to occur or not, see if
/usr/include/dev/acpica is a directory or a file--if it's a directory,
you're fine, if it's a file, delete it before running make

- -- 

Scott Robbins

PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver --recv-keys EB3467D6

Spike: We're out of Wheat-a-Bix. 
Giles: We are out of Wheat-a-Bix because you ate it all. Again. 
Spike: Get some more. 
Giles: I thought vampires were supposed to eat blood. 
Spike: Yeah, well, sometimes I like to crumble up the Wheat-a-Bix
 in the blood. Gives it a little texture. 
Giles: Since the picture you just painted means that I will never
touch food of any kind again, you'll just have to pick it up 
Spike: Sissy. 

Version: GnuPG v1.4.0 (FreeBSD)


More information about the freebsd-stable mailing list