Floppy problems

Doug White dwhite at gumbysoft.com
Wed Mar 9 19:33:53 PST 2005

On Mon, 7 Mar 2005 pbowen at fastmail.fm wrote:

> Sirs:
> I'm having a problem doing "newfs" to a floppy on a new installation. I tried
> changing to a new floppy and get the same thing.
> # fdformat -f 1440 /dev/fd0
> Format 1440K floppy `/dev/fd0'? (y/n): y
> # bsdlabel -B -w /dev/fd0 fd1440
> # newfs /dev/fd0
> newfs: wtfs: 512 bytes at sector 2879: Input/output error

Can't say I've ever tried to make a UFS filesystem on a floppy, but sector
2879 is off the end of the disk.  newfs probably needs a hint for the disk
size.  'newfs -T fd1440 /dev/fd0' may work better.

> # newfs_msdos /dev/fd0
> /dev/fd0: 2840 sectors in 355 FAT12 clusters (4096 bytes/cluster)
> bps=512 spc=8 res=1 nft=2 rde=512 sec=2880 mid=0xf0 spf=2 spt=18 hds=2 hid=0
> newfs_msdos: /dev/fd0: Input/output error

The previous newfs proble may have corrupted the floppy. Try fdformat
again then newfs_msdos. If you still get an error check the kernel
messages (dmesg) for any errors from the fd driver.

Doug White                    |  FreeBSD: The Power to Serve
dwhite at gumbysoft.com          |  www.FreeBSD.org

More information about the freebsd-stable mailing list