Floppy problems in 5.3

Daniel O'Connor doconnor at gsoft.com.au
Wed Mar 9 16:16:24 PST 2005

On Thu, 10 Mar 2005 06:32, pbowen at fastmail.fm wrote:
> # bsdlabel -B -w /dev/fd0 fd1440
> # newfs /dev/fd0
> newfs: wtfs: 512 bytes at sector 2879: Input/output error
> # newfs_msdos /dev/fd0
> /dev/fd0: 2840 sectors in 355 FAT12 clusters (4096 bytes/cluster)
> bps=512 spc=8 res=1 nft=2 rde=512 sec=2880 mid=0xf0 spf=2 spt=18 hds=2
> hid=0 newfs_msdos: /dev/fd0: Input/output error
> #

Do you get anything in dmesg from these?

> If I take a linux formatted floppy, mount it, then "ls" on the mount point,
> I can get the dir listing. Or if I "less" a file on the floppy I can read
> the contents. Any attempt to use "vi" or to write to the floppy fails with
> another "Input/Output error". Of course, the same drives and floppies
> mount, read, and write under Minix, Slackware-10.0 and FreeBSD 4.11.

Tried that floppy drive with a different OS, or tried a different drive with 

Daniel O'Connor software and network engineer
for Genesis Software - http://www.gsoft.com.au
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20050310/f7012100/attachment.bin

More information about the freebsd-stable mailing list