ndis problem with stable kernel source

Daniel O'Connor doconnor at gsoft.com.au
Thu Mar 3 06:58:00 GMT 2005


On Thu, 3 Mar 2005 16:50, Nicholas Basila wrote:
> Well, I've been using the official HP driver. I ran the utility like so:

I don't know where the official HP driver is (hint: a URL would be handy)

> ndiscvt -i name_of_nt_driver.inf -s name_of_nt_driver.sys -o
> /tmp/ndis_driver_data.h
>
> I then copied it to the compile directory of my kernel. Make depend runs
> correctly, but it crashes out during the linking phase of make. I have
> these options at the bottom of my kernel config:
>
> options NDISAPI
> device ndis
> device wlan

I would suggest building it as a module as it's much simpler (unless you're 
booting over this interface - which is doubtful)

eg..
cd /usr/src/sys/modules/if_ndis
cp /tmp/foo.inf /tmp/foo.sys .
ndiscvt -i foo.inf -s foo.sys -o ndis_driver_data.h
make
make install

> As I said, this worked perfectly with 5.3 and even 5-current before the
> 5.3 release. I tried building the stable version of ndiscvt, and that
> didn't produce a different header file. I did a cvsup two days ago, got
> the error, and did a new cvsup tonight.

Make sure your userland and kernel are in sync - ie install world to match 
your new kernel. You may be building against stale headers.

-- 
Daniel O'Connor software and network engineer
for Genesis Software - http://www.gsoft.com.au
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20050303/13b395b0/attachment.bin


More information about the freebsd-stable mailing list