Crash when PREEMPTION enabled

Kris Kennaway kris at
Thu Mar 3 04:56:59 GMT 2005

On Tue, Mar 01, 2005 at 07:13:04PM +1100, Peter Jeremy wrote:
> I have tried enabling PREEMPTION on 5.3-RELEASE-p5 whilst it ran OK
> for a few hours, it crashed overnight whilst doing a "make index" in
> /usr/ports.  I've tried repeating "make index" and it worked.  I have
> a coredump of the crash and have been doing some poking around.

I've just turned on PREEMPTION on the 12-CPU sparc64 machine running
RELENG_5 that I've been playing with, and it quickly resets and
reboots under load (buildworld -j12).  This happens with either ULE or
4BSD, although ULE without PREEMPTION seems to work fine (and perform
much better than 4BSD, as expected).

It looks like PREEMPTION is indeed still broken in RELENG_5 - I guess
my workloads aren't enough to trigger this on other machines :-(

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-stable mailing list