[SOLVED] VIA M1000 mini-itx system installation woes - WRITE_DMA error

W C woodycarey at hotmail.com
Thu Apr 28 13:20:59 PDT 2005

This solution worked like a charm!  Thanks Arjan!

One note:  use "set ..." syntax in the interactive loader prompt (6), and 
"hw.ata.ata_dma="0" *without* "set " in /boot/loader.conf

Interestingly, setting the drive in the BIOS to PIO4 mode had no effect.

Now if I can just get carrier on my vr0 interface, I won't have to return 
this system!


>From: Arjan Van Leeuwen <avleeuwen at gmail.com>
>Reply-To: Arjan Van Leeuwen <avleeuwen at gmail.com>
>To: W C <woodycarey at hotmail.com>
>CC: freebsd-stable at freebsd.org
>Subject: Re: VIA M1000 mini-itx system installation woes - WRITE_DMA error 
>Date: Wed, 27 Apr 2005 10:11:16 +0200
>On 4/26/05, W C <woodycarey at hotmail.com> wrote:
> > Hi all,
> >
> > I am attempting to install 5.3-R from cd (iso image download)  and
> > sysinstall is failing
> > to write the chosen (Auto Layout) filesystem to disk, the Toshiba 80G on 
> > primary ide channel as master.   The error on vty1 is (from memory) ad0:
> > WRITE_DMA, error=84.
> > The drive is detected by BIOS as a UDMA100 device.  There is nothing 
>else on
> > this IDE channel, and only a cd drive on the other IDE slot.
> >
> > A search of -questions reveals this error is a UDMA mismatch, possible
> > caused by 80-pin cabling, and fixable with atacontrol ad0 udma33 pio bla 
> > bla.  However, I do not yet have a running system to run atacontrol 
>from, as
> > I am installing.  I have rooted around in the bios for an option to 
> > the drive to UDMA33 speed, to no avail.  Does anyone know how I can work
> > around this problem and  install FreeBSD to this neat little system?  Do 
> > have bad cabling, a bad drive, or ???
>Yes, I had the same problem.
>If this is a 2.5" drive, it probably doesn't have a 80-pins cable.
>Force PIO mode for the install by entering at the boot prompt (option
>6 in the boot loader menu):
>   set hw.ata.ata_dma="0"
>   boot
>After you've installed the system, insert that line into
>/boot/loader.conf, and load up "atacontrol mode 0 udma33 udma33" as
>early as possible during the boot (try using /etc/rc.early, for
>example) to get it up to speed again.
>freebsd-stable at freebsd.org mailing list
>To unsubscribe, send any mail to "freebsd-stable-unsubscribe at freebsd.org"

On the road to retirement? Check out MSN Life Events for advice on how to 
get there! http://lifeevents.msn.com/category.aspx?cid=Retirement

More information about the freebsd-stable mailing list