Kodak USB flash reader causes freezes, panics

Tim Howe tim.howe at celebrityresorts.com
Wed Apr 27 20:59:02 PDT 2005

Brooks Davis <brooks at one-eyed-alien.net> writes:

>> > > Reproducibly, if I begin copying data to a [...] CF card [...] it
>> > > works for a while, then freezes the system.
> Sounds like you should file a PR about the issue.  Are you sure the file
> system in question is OK?  There were some msdosfs corruption bugs fixed
> recently.

Taking your suggestion I zeroed out the CF card, then used fdisk and
newfs_msdos to get it in working order again.  I've been testing it
over the past week and have had no problems since.

Thanks for the pointer.  Is it accepted for a corrupt filesystem to
freeze the system, though?

>> [1042] ~ # true > /dev/da0               
> I'd highly recommend running the command in the other direction so you
> try to read rather than write.  It shouldn't matter, but that makes me
> nervous (not that I think it has anything to do with your problem.)

I tried that, and doing a read and waiting a few seconds.  Opening for
write, as above, worked immediately.

Tim Howe
Software Engineer
Celebrity Resorts

More information about the freebsd-stable mailing list